Как получить прогноз погоды в Excel

В прошлом посте мы разобрались как Как получить курсы валют из интернета в Excel или Таблицы Гугл. Теперь мы попробуем получить прогноз погоды в Excel. У меня предпоследняя версия Excel, но работать будет и в ближайших. Смотрите, что у меня получилось. Если нравится, то начнем.

прогноз погоды в Excel

Находим источник данных о погоде для Excel

Запускаем Excel. Я покажу на данных с двух сайтов погоды. Вы можете выбрать из них или найти свой. Эти ссылки нам понадобятся. Обратите внимание, что у меня выбран Санкт-Петербург. Если вы хотите выбрать другой город, то откройте сайт, выберите свой город и скопируйте ссылку из строки браузера.

Ничего сложного делать не будем. Обрабатывать данные в Power Query тоже не будем, иначе материал будет сложноват для новичков.

Запускаем браузер по ссылке, находим город и копируем ссылку из адресной строки. Вот так это будет выглядеть.

прогноз погоды в Excel

Красным я выделил таблицу из которой будем получать данные.

И то же самое для второго сайта. Нам нужна адресная строка с вашим городом.

прогноз погоды в Excel

Импортируем данные о погоде в Excel

Запускаем Excel. Переходим на вкладку Данные и в блоке Получить и преобразовать данные выбираем Из Интернета. В окошке вставляем ссылку и жмём ОК.

прогноз погоды в Excel

Данные начнут загружаться и откроется таблица Навигатор. Если всё сделали правильно, то мы увидим слева дерево таблиц. В нашем примере будем использовать таблицу 1. В дальнейшем вы можете использовать любые таблицы, которые вам будут больше подходить.

Часто удобнее (но сложнее новичку) сразу преобразовать данные в Power Query, но мы решили, что делать этого не будем, так что нажимаем Загрузить, а не Преобразовать данные.

Таблица загрузится. Сразу обновим свойства подключения. Настроим обновления данных. При открытии, через промежутки времени и по команде. Таким образом Excel будет автоматически обновлять сводку погоды.

Формулы, форматирование прогноза погоды

На отдельном листе размещаем необходимые данные из таблицы. Копируем значения нужных ячеек.

Формула =’Table 1′!F5 скопирует значение из таблицы 1, ячейки F5.

Формула =’Table 1′!F6 скопирует значение следующей строки этого же столбца, из таблицы 1, ячейки F6.

Температуру, теплоощущение, влажность мы скопировали. Как я преобразовал англоязычные подписи?

С помощью служебной таблички. Левый столбик так как в оригинале, справа перевод, а третий столбик занял значками.

Как вставить изображения в ячейки Excel

Дело в том, что Excel не позволяет использовать в формулах изображения. Поэтому я использовал символьный шрифт Webdings. Сайт эти значки отобразить корректно не может, вот что получается.

ÕÖ×ØÙÚÛÜÝ

Но если скопировать эту строчку в Word или Excel и переключиться на шрифт Webdings, то мы увидим изображения.

Но так как это по сути шрифт, то все операции в ячейке с ним можно проводить так же как с текстом.

С помощью этой таблицы я осуществил перевод. В ячейке куда выводятся осадки, я ввел формулу:

=ВПР(‘Table 1’!F3;E34:F39;2;)

Функция ВПР берет значение ячейки F3 в Таблице (Table 1) на английском (cloudy) и ищет соответствие в моей табличке E34:F39. Как только находит в 1 столбце выделенного E34:F39 диапазона слово cloudy, то копирует в ячейку Осадки соответствующее значение из 2 второго столбца диапазона ячейки правее (облачно).

Точно так же работает и вывод туч и облаков. Формула:

=ВПР(F11;F34:G39;2;)

Если в ячейке F11 слева появилось слово, то функция ВПР ищет в таблице F34:G39 соответствия и копирует в свою ячейку (G12) данные из столбца 2 совпавшей ячейки в столбце 1.

Надеюсь, что у вас получилось. Даты можно указать как функцию =СЕГОДНЯ(), =СЕГОДНЯ()+1 для завтрашней даты и т.д.

Условное форматирование ячеек

Теперь хорошо бы раскрасить ячейки в зависимости от состояния погоды. Закрашивать будем не ячейки, а наши значки. Создадим правило для каждой ситуации.

И далее выбираем ячейку и формат. Если выбрать пользовательский, то можно настроить цвет фона, цвет шрифта, как сделано в этом примере.

Таким образом мы имеем правила для одной ячейки по количеству ситуаций с облаками. Ниже видно, что цвет шрифта для каждого правила свой.

В принципе и всё. Погода загружается, данные меняются, облачка сменяются тучками. На этой основе вы можете сделать любой другой вывод прогноза погоды в Excel.

Только обратите внимание, что прогноз идет по часам и столбцы в исходном файле как бы смещаются влево. То есть прогноз на утро прошлого дня уже не отображается на сайте, а ваши формулы всё еще пытаются вытащить эти данные. Нужно продумывать все для каждого конкретного случая. Например, сравнивая даты или другим способом.

Как получилось на другом сайте по ссылке в начале поста:

Я не смог придумать как бы необычнее это сделать, так что просто сложил выборку рядом.

При том, что Excel может тащить из интернета различные табличные данные, то при должном старании и необходимости можно автоматически получать и обрабатывать большое количество данных.

Читайте нас в Telegram или Facebook

Поделиться в сетях:



Сейчас читают:  Какой браузер лучше показывает потоковое видео 4К, 8К
Войдите (зарегистрируйтесь) с помощью вашего аккаунта: 
0 прокомментировали
Встроенные отзывы
Посмотреть все комментарии